Materials Phase

In the Materials Phase in Pool Studio, you can apply materials from the library to surfaces and objects in your design. The features in this phase only work in the 3D view. While you can still view your design in 2D, you will only be able to apply materials in the 3D view. You must select the surface before you can apply a material to it.

In the Materials Phase in Pool Studio, you can apply materials from the library to surfaces and objects in your design. The features in this phase only work in the 3D view. While you can still view your design in 2D, you will only be able to apply materials in the 3D view. You must select the surface before you can apply a material to it.

In VizTerra, you can apply materials from the library to surfaces and objects in your design in the Materials Phase. The features in this phase only work in the 3D view. While you can still view your design in 2D, you will only be able to apply materials in the 3D view. You must select the surface before you can apply a material to it.

Selecting Multiple Surfaces with Quick Selection

VizTerra Selecting Multiple Surfaces with Quick Selection
Pool Studio Materials Selecting Multiple Surfaces with Quick Selection
Pool Studio Materials Selecting Multiple Surfaces with Quick Selection

Quick Selection: Quick Selection allows you to select all objects of a specific type at once. This allows you, for example, to change all your decks in Pool Studio or hardscapes in VizTerra to the same material with a single click. Simply click on the Quick Selection button and you will select all the objects of that type. For example, clicking on the House button will select all the shapes in the design drawn in the House Stage.

If any of the Quick Selection buttons are grayed out, it means that your project does not contain any objects of that type, or that you are in the 2D view.

Select All: The Select All button will select all the surfaces and objects in your design to which materials may be applied.

Select None: The Select None button will clear all your currently selected surfaces. This will also clear the red highlight allowing you to see your applied material.

Selecting Individual Surfaces

VizTerra Selecting Individual Surfaces
Pool Studio Materials Selecting Individual Surfaces
Pool Studio Materials Selecting Individual Surfaces

Selecting Surfaces: If you wish to change one individual surface, you may select it by double left clicking directly on it. Selected surfaces will highlight in red.

To select more than one surface at a time, hold down the CTRL button on your keyboard and left-click once on each additional surface. At any time, you can cancel your selection by pressing the Select None button.

Selection in 3D in Materials: You will find that selection in 3D in the Materials Phase works differently than in other phases. Instead of selecting and moving objects with the 3D gizmo, you have the ability to select the surfaces of shapes and apply materials. This includes house pieces and custom shapes which you can select in other stages as well as pool shapes, decks, planters in Pool Studio and water features, hardscapes, planter beds in VizTerra, as well as all other drawn shapes which you normally cannot select in 3D. You will not be able to select most items inserted from the library unless they include drawn shapes.

Each different type of shape has a different number of surfaces. Shapes drawn in the House Stage for example have only one surface. Each house piece may only have one material applied to it. When you select the house piece the entire shape will highlight in red. If you have multiple house pieces in your design, you may apply a different material to each house piece, but only one material per piece. Pool shapes in Pool Studio and hardscapes in VizTerra have multiple surfaces. In Pool Studio, the interior, tile line, and coping of the pool (the exterior, tile line, and coping edge of the hardscape in VizTerra) may each have different materials applied. The red highlighting shows you exactly which surface is selected.

The Copy and Paste commands also work differently here in the Materials Phase. In other phases, you can copy and paste objects. In the Materials Phase, you can copy and paste materials on surfaces in your project.

Selecting Painted Materials: You are also able to select materials which have been painted onto the terrain with the Paint tool in the Property Slope Stage in Pool Studio or the Terrain Stage in VizTerra. Each material that has been painted onto the terrain with the Paint tool is its own surface and may be selected by double clicking on it. If you selected any one spot where the material has been painted, it will automatically select every spot where the material has been painted. If you change a painted material, every spot on the terrain where it has been painted will change.

Multiple materials can be painted on top of one another, layering multiple surfaces. This may make it difficult to select just one material. The Select by Material button located under the Currently Used Tab in the Materials Library can assist in selecting painted materials.

Changing painted materials here in the Materials Phase will change the corresponding Material Slot in the Property Slope Stage in Pool Studio or Terrain Stage in VizTerra.

Materials Library

The Materials Phase has a unique library different from the other phases. The Materials Library does not contain the templates, items, and landscaping contained in the main library on other phases. Instead it contains materials you can apply to surfaces in your design.

The Materials Library has 5 Tabs at the top, Materials, Favorites, Currently Used, New Materials Added, and Search.

Materials Tab:

VizTerra Materials Library Tab
Pool Studio Materials Library
Pool Studio Materials Library

The Materials Tab contains materials which can be applied to surfaces in your design.

The Materials Tab contains a row of Category buttons. Left clicking on a Category button will bring up pictures of the materials organized by type in Pool Studio, and the names of the materials organized in VizTerra.

Materials under the Materials Tab may be selected by left clicking on the material picture or name. The materials may be applied by double left clicking on the picture or name or using the Insert or Insert One buttons below.

The Materials Tab contains materials for all the surfaces in your design. This includes materials for use on the ground such as grass, dirt, and sand; materials for structures such as different concrete, stone, brick, and metal materials. In Pool Studio, materials for specific items such as fence, roof, decking, and pool interior materials are also included. In VizTerra, materials for specific items such as fence, roof, and hardscape materials are included. This tab also contains specific materials from vendors and manufacturers.

Favorites Tab:

VizTerra Materials Library Favorites Tab
Pool Studio Materials Library Favorites Tab
Pool Studio Materials Library Favorites Tab

The Favorites Tab allows you to create a list of materials you commonly use for quick access. This makes it easy to find and apply the materials you use most often into your designs.

Materials in the Favorites list may be selected by left clicking on the picture (Pool Studio) or name of the material (VizTerra). The material may be applied by double left clicking on the picture or name of the material or using the Insert or Insert One buttons below.

Materials in the Favorites list are listed alphabetically by material name. The location of the material in the Materials Library is displayed underneath the Tab row. The Tab, Category, Type, and Name of the material is listed.

Adding Materials to Favorites: Any material in the library may be added to this list by selecting the material in the library and clicking on the Favorites Button located beneath the library list.

Removing Materials from Favorites: When viewing the favorites list under the Favorites Tab you may remove any material by selecting the material in the list and clicking on the Favorites Button located beneath the library list.

Favorites Button: The Favorites Button is the star button located underneath the library list.

Currently Used Tab:

VizTerra Material Library Currently Used Tab
Pool Studio Materials Library Currently Used Tab
Pool Studio Materials Library Currently Used Tab

The Currently Used Tab displays a list of all the library materials currently applied to surfaces in the design. This makes it easy to see which materials have been applied to surfaces in the design and apply those materials on more surfaces.

Materials in the Currently Used list may be selected by left clicking on the picture (Pool Studio) or name of the material (VizTerra). The material may be applied by double left clicking on the picture or name of the material or using the Insert or Insert One buttons below.

The materials in the Currently Used list are divided into two different groups, Currently Used and Property Materials.

The Currently Used group contains all the materials that have been applied to the surfaces of shapes such as house pieces and pool (Pool Studio) or hardscape (VizTerra) shapes.

The Property Materials groups contains all the materials that have been applied to the terrain, especially materials that have been painted onto the terrain with the Paint Tool in the Pool Studio Property Slope Stage or VizTerra Terrain Stage.

Materials in both groups of the Currently Used list are listed alphabetically by material name. The location of the material in the Materials Library is displayed underneath the Tab row. The Tab, Category, Type, and Name of the material is listed.

As with other materials in the library, materials in the Currently Used list may be added to Favorites by selecting the material and clicking on the Favorites button.

Select by Material: This button is only available on the Currently Used Tab. With a material selected in the list, this button will select all the surfaces that have the selected material applied. This makes it easy to quickly replace an applied material with a new one on multiple surfaces. This is especially helpful if you an object made out of shapes from different stages such as a house made of both house pieces and custom shapes. This button is also useful when changing Material Slots in the Pool Studio Property Slope Stage or VizTerra Terrain Stage.

Property Slope or Terrain Material Slots: In the Pool Studio Property Slope Stage (and VizTerra Terrain Stage), it is possible to use the Paint tool to paint materials onto the terrain. When using the Paint tool, you are able to select from 10 different Material Slots. You may change the materials in the Material Slots here on the Materials Stage.

Select the painted material by double clicking on it. All spots on the terrain where the material has been painted will be automatically selected. Replace the painted material with a new material from the library. The material in the design will change and the Material Slot back in the Pool Studio Property Slope Stage or VizTerra Terrain Stage will be updated with the new material. The Jump to Materials Phase button under Parameters in the Property Slope or Terrain stage makes it easy to jump from Property or Terrain to Materials.

Painted materials will appear under the Currently Used tab in the Property Materials group. For more information on painted materials, the Paint tool, and Material Slots please see the Pool Studio Property Slope Stage or VizTerra Terrain Stage.

Using Copy and Paste with Materials:

VizTerra Materials Phase Copy and Paste

Materials that have already been applied to surfaces in your design may be copied and pasted using the Copy and Paste commands found in the Edit menu. In other Phases, these commands are used to copy and paste objects. Here in the Materials Phase, though these commands allow you to copy and paste materials. This is the fastest way to apply materials you are currently using in your design to new surfaces.

Copying a Material: In order to copy a material, you must first select a surface the material is applied to by double clicking on the surface. You can then copy the material by going to the Edit menu and selecting Copy or pressing CTRL+C on your keyboard. Nothing will happen on your screen, but the material will be copied. Please note that the copy command will not work if you have more than one surface selected.

Pasting a Material: You may paste a copied material onto any selected surface or group of surfaces. Simply select Paste from the Edit menu or press CTRL+V on your keyboard. The material you copied last will then be pasted onto the selected surface or group of surfaces.

New Materials Added Tab:

VizTerra Materials Library New Materials Tab
Pool Studio Materials Library New Materials Added
Pool Studio Materials Library New Materials Added

The New Materials Added Tab displays a list of all the new materials added to the library in the most recent update to the program. This makes it easy to see all the new materials and start using them in designs.

Materials in the New Materials Added list may be selected by left clicking on the picture (Pool Studio) or name of the material (VizTerra). The material may be applied by double left clicking on the picture or name of the material or using the Insert or Insert One buttons below.

Materials in the New Materials Added list are listed alphabetically by material name. The location of the material in the Library is displayed underneath the Tab row. The Tab, Category, Type, and Name of the material is listed.

As with other materials in the Library, items in the New Materials Added list may be added to Favorites by selecting the material and clicking on the Favorites button.

Search Tab:

VizTerra Materials Library Search Tab
Pool Studio Materials Library Search Tab
Pool Studio Materials Library Search Tab

This tab allows you to search for materials in the Library by name. This is the fastest way to find a material and apply it in the design.

Searching for Materials: To search for a material, simply type the name of the material into the Search bar and press the Search button. The results of the search will appear below. Single words or groups of words may be entered into the Search bar. You may type in a specific material name such as White Peppered Rock or type in a category name such as Earth. The search feature will search material names, categories, types, and subtypes.

Search Options: The drop down box to the left of the Search bar allows you to choose from three different search options, All Words, Any Words, and Exact Phrase. All Words will return materials that that match all of the words typed into the Search bar. Any Words will return materials that match any of the words typed into the Search bar. Exact Phrase will only return materials that exactly match the words typed into the search bar.

Materials Found by the Search: Materials found by the search may be selected by left clicking on the picture in Pool Studio or the name of the material in VizTerra. The material may be inserted by double left clicking on the picture or name of the material or using the Insert or Insert One buttons below.

Materials found by the search are listed alphabetically by material name. The location of the material in the Library is displayed underneath the Tab row. The Tab, Category, Type, and Name of the material is listed.

As with other materials in the Library, materials found by the search may be added to Favorites by selecting the material and clicking on the Favorites button.

Materials Library Buttons:

VizTerra Materials Phase Library Buttons
Pool Studio Materials Phase Library Buttons
Pool Studio Materials Phase Library Buttons

The Materials Library Buttons allow you to perform many different actions with the library. We will consider each of the different buttons and their functions.

Tab View:

VizTerra Materials Phase Tab View Buttons
Pool Studio Materials Phase Buttons Tab View
Pool Studio Materials Phase Buttons Tab View

The “1” button will switch the library into Tab View. In this view, materials are sorted under Type bars which can be collapsed and expanded as necessary. The materials are represented by pictures under each bar. You can right click on each picture for an enlarged image of the item.

Outline View: The “2” button will switch the library into Outline View. In this view, the materials are sorted in brackets by Type name. Variations are bracketed under the material name. An image of each material will appear to the left of the list when the material name is selected.

Favorites Button: The star button allows you to add the material currently selected in the library to your Favorites list. All Favorites are listed under the Favorites Tab. Any material in the library including materials in the Currently Used and New Materials lists as well as Search results can be added to Favorites. Pressing this button with a material selected in the Favorites list will remove the item from Favorites.

Select by Material: This button is only available on the Currently Used Tab. With a material selected in the list, this button will select all the surfaces that have the selected material applied. This makes it easy to quickly replace an applied material with a new one on multiple surfaces. This button is also useful when changing Material Slots in the Property Slope Stage.

Replace Selected: This button is not used in the Materials Library.

Insert and Insert One:

VizTerra Materials Phase Insert and Insert One Options
Pool Studio Materials Phase Insert and Insert One Option
Pool Studio Materials Phase Insert and Insert One Option

Both Insert and Insert One will apply the currently selected material onto the currently selected surface or surfaces in the design. Both buttons perform the same action. You may also apply materials by double clicking on them.

Save: In VizTerra, this button is not used in the Materials Library. You may save custom materials you create on the Customize Materials Phase using the Save button located in the Panel on that stage.

In Pool Studio, the Save button will allow you to save materials you have customized on the Customize Materials Phase to the library.
Pool Studio Materials Phase Save Option

When you press the Save button, the Create Template box will come up. This box will display a preview image of the material you are saving to the library. You may select the Category and Type you would like the material saved to from the drop down lists and give your new material a Name. You may also enter a Description for the material if you would like. If you would like to create a new category or type to save the material to, simply type in the new category or type name instead of selecting from the drop down list. Press the Ok button when you are done to save the material to the library.

Edit:
Pool Studio and VizTerra Materials Phase Edit Option
The Edit button is used to edit custom materials you have saved to the Materials Library. If a custom material you have saved to the library is selected, Edit will bring up the Edit Template box and allow you to edit the Category, Type, Name, and Description of the custom material. The Edit button allows you to move custom materials between Categories and Types. You can also create new Categories and Types by typing in new category and type names instead of selecting a choice from the drop down menu. The Edit button only allows you to edit custom materials, you cannot edit the standard materials in the library.

Delete:
Pool Studio and VizTerra Materials Phase Delete Option

Delete will permanently delete a custom material from the library. Please remember this will remove the custom material from the library for all projects and cannot be undone.

Material Manipulation

Pool Studio Material Manipulation

With these controls you can adjust materials you have already applied to surfaces in the design. Select the applied material and then manipulate its appearance with the controls. This is very useful when you need a material to line up and appear properly across a surface or when you want to reflect a certain product or style.

Scale: This slider will scale the pattern of the currently selected material.

Rotate: This slider will rotate the pattern of the currently selected material.

Pan: This button will allow you to pan the selected material. This allows you to adjust and line up materials such as the plank lines in wood materials to appear properly across a surface.

Reset: This button will reset a selected material back to its original state.

Object Properties

Pool Studio Materials Object Properties

Object Properties allows you find the surface area of a currently applied material. For example, this feature allows you to quickly calculate the surface area of the interior of your pool or water feature, or the total surface area of all your decking or hardscapes.

Selecting an applied material will display the material’s name and surface area under Object Properties. Selecting multiple surfaces will give you a total area. Clicking the Deck Quick Selection button in Pool Studio (Hardscapes Quick Selection in VizTerra), for example, will give you the total area of all of your deck pieces.

NOTE: These calculations, although 100% accurate in the software, should be used as a guide. This is due to how the objects are created in 3D.