Importing AutoCAD® Files

Import Information from an AutoCAD® File into a Pool Studio or VizTerra Project.

Pool Studio and VizTerra have the ability to import 2D AutoCAD files. This allows you to convert your 2D AutoCAD projects into fully interactive 3D presentations with a few clicks of the mouse.

Information from DWG files, the native file format for Autodesk’s AutoCAD software, can be copied directly into Pool Studio or VizTerra projects. Pool Studio and VizTerra can also import information from DXF files. This allows you to import templates, landscaping symbols, and whole 2D design projects into Pool Studio.

File Menu

Pool Studio File Menu Import AutoCAD FileVizTerra AutoCAD File Menu

To import an AutoCAD file go to the File Menu, select Import, and then select AutoCAD file.

AutoCAD File Formats: Only AutoCAD files in the DWG or DXF formats can be imported. Files in other formats will need to be converted before being imported.

How the Information is Imported: Pool Studio or VizTerra only copies the information from the AutoCAD file. It does not actually open the file. Nothing done in Pool Studio or VizTerra will change the original AutoCAD file. Also any changes made to the file in AutoCAD will not be reflected in Pool Studio or VizTerra unless the file is imported again.

Information that Will Not Import: Only lines and symbols will be imported. Text, lines colors, styles, and weights as well as other information will not be imported. Also object heights and depths are not imported and will have to be set under Stage Options.

AutoCAD File Name: The name of the imported AutoCAD file will appear in the top left of the screen in parentheses after the Pool Studio or VizTerra project file name. The name will remain there until either the AutoCAD view is closed or the Pool Studio or VizTerra project is closed. Imported AutoCAD files are not saved with the Pool Studio or VizTerra project sav file.

AutoCAD View

Pool Studio AutoCAD ViewVizTerra AutoCAD View

Once an AutoCAD file has been imported, the 2D viewport will display a split screen. The regular grid is now the top half of the screen and the contents of the AutoCAD file are displayed in the bottom half of the screen.

Please Note: The AutoCAD view does not appear on all stages. It only appears on stages with drawing tools.

Adjusting and Closing the AutoCAD View: The AutoCAD view can be collapsed by pressing the triangle in the top right of the AutoCAD view. Pressing the triangle again will expand the menu. The height of the AutoCAD view can be adjusted by holding down the left mouse button on the center bar and dragging the view up or down. The AutoCAD view may be closed by pressing the X.

Please Note: Closing the AutoCAD view will remove the AutoCAD file from the Pool Studio or VizTerra Project. Once you close the view, you will need to import the AutoCAD file again.

Moving within the Views: The AutoCAD view has the same basic pan and zoom controls as the grid. The grid and the AutoCAD view may be locked to the reference points so that both will pan and zoom together or the views may be independent of each other. Remember that lines from the AutoCAD view will always import based on the location of the reference points, not the section of the grid that is currently being viewed. The grid and the AutoCAD view may be locked using the button in the AutoCAD view menu.

Reference Points: The reference points are represented by pink plus signs. One point appears in the AutoCAD view and one point appears in the grid. When lines are imported they will always appear relative to the placement of the reference point. The reference points may be hidden using the button in the AutoCAD view menu.

Importing from the AutoCAD View into Pool Studio or VizTerra: Any selected line or shape may be imported from the AutoCAD view into the Pool Studio or VizTerra project by using the Import button. Unlike Pool Studio and VizTerra, many shapes in AutoCAD are incomplete. In order for these imported shapes to appear in 3D they must be completed. This can be done by using the Group button to weld the lines together or by using the Line and Arc tools to complete the shapes.

Please Note: Make sure to set the AutoCAD scale before importing.

AutoCAD View Menu

Pool Studio AutoCAD View MenuVizTerra AutoCAD View Menu

The AutoCAD View Menu is located in the center at the top of the AutoCAD view.

Pool Studio AutoCAD Pan ToolPan: Pan allows you to shift the AutoCAD view left to right and up and down. This helps you to view everything if the plan in the AutoCAD file is larger than the view. You can also pan by holding down the center mouse wheel. Pan works exactly the same in the AutoCAD view as it does in the grid.

VizTerra AutoCAD Zoom Tool Pool Studio AutoCAD Zoom ToolZoom: Zoom allows you to zoom the AutoCAD view in and out. You can also zoom by using the mouse wheel. Zoom works exactly the same in the AutoCAD view as it does in the grid.

VizTerra AutoCAD Zoom to Extents Tool Pool Studio AutoCAD Zoom to Extents ToolZoom to Extents: Zoom to Extents will zoom the AutoCAD view so that a currently selected object fills the view. If nothing is selected, it will zoom out so that all items can be seen. Zoom to Extents works exactly the same in the AutoCAD view as it does in the grid.

VizTerra AutoCAD Hide Unhide Reference Points Pool Studio AutoCAD Hide Unhide Reference Points ToolHide/Unhide Reference Points: This button will hide the reference points. If the reference points are hidden, this button will reveal them.

VizTerra AutoCAD Lock AutoCAD to 2D View Pool Studio AutoCAD Lock AutoCAD View to 2DLock AutoCAD View to 2D View: This button will lock the AutoCAD view to the grid of the 2D view so that each view will move and scale at the same time.

VizTerra AutoCAD Display as Background Image Tool Pool Studio AutoCAD Display AutoCAD as Background ImageDisplay AutoCAD View as Background Image: This button will collapse the AutoCAD view and display the AutoCAD file as a background image. This allows the AutoCAD file to be used as guide to trace lines which would not be useful to import. The Display AutoCAD view as Background Image button will appear on the 2D view tool bar while the AutoCAD view is displayed as a background image. Pressing the button will remove the background image and return the AutoCAD view to normal.

VizTerra AutoCAD Import Tool Pool Studio AutoCAD Import ToolImport: This button will import the currently selected line or shape from the AutoCAD view into the project.

Please Note: Make sure to set the AutoCAD scale before importing.

AutoCAD View Menu

Pool Studio AutoCAD View Menu UnitsVizTerra AutoCAD View Menu UnitsLines drawn in AutoCAD are measured in units. These units may be set to any length depending on the scale being used for the project. The AutoCAD scale is not saved in the AutoCAD file so the scale must set before importing objects.

Scale: The AutoCAD scale drop down box is located at the top right of the AutoCAD view. From the drop down menu you can set the length of the dwg units. You can choose one of the common lengths or set a custom scale.

Printing Scale: The AutoCAD scale is the drawing scale. The drawing scale and the printing scale are different. In both AutoCAD and Pool Studio or VizTerra you choose your printing scale when actually printing your design, not during the design process.

AutoCAD Options

Pool Studio AutoCAD OptionsVizTerra AutoCAD OptionsThe AutoCAD Options section is located in the Panel. It contains several controls for the AutoCAD view.

Layers: This box lists all the layers in the AutoCAD file. You may hide and unhide the layers in this box.

Spaces and Blocks: This box lists all the Spaces and Blocks in the AutoCAD file. You may select the different spaces and blocks from this list.

Hide Selected: This button will hide the line or shape currently selected in the AutoCAD view.

Unhide Selected: This button will unhide the hidden line or shape currently selected in the AutoCAD view. To use this button you will have to turn on Show hidden objects and Make hidden objects selectable.

Show Hidden Objects: Turning this option on will show lines and shapes which have been hidden in the AutoCAD view. The color of these lines and shapes can be chosen using the color button to the right of the check box. In order to select hidden objects you will have to turn on Make hidden objects selectable.

Make hidden objects selectable: Turning this option on will allow you to select lines and shapes which have been hidden in the AutoCAD view. Having this option turned on allows you unhide objects in the AutoCAD view. In order for this option to be available you must turn on Show Hidden Objects.

Change imported object color: With this option turned on, lines and shapes will change color when imported from the AutoCAD view into the Pool Studio or VizTerra project. The color of imported objects can be chosen by using the color button to the right of the check box.

Layers:

Pool Studio AutoCAD LayersVizTerra AutoCAD LayersThe Layers box lists all of the layers in the AutoCAD file. The number of layers used and the names for each layer are chosen while the file is being created in the AutoCAD program. Pool Studio and VizTerra simply import the information already contained in the AutoCAD file. If you do not create your own AutoCAD files you may find that files you import do not use layers or use confusing layer names.

Layer Names: Layer names are chosen when the file is created in the AutoCAD program. It is not possible to change the layer names in Pool Studio or VizTerra. Pool Studio and VizTerra simply copy the layers and names saved in the AutoCAD file.

Selecting and Hiding Layers: Layers may be selected by left clicking on their name. Highlighted layers are selected and currently visible in the AutoCAD view. Layers that are not highlighted are not selected and are hidden in the AutoCAD view. You may have all or none of the layers visible when working in the AutoCAD view.

Please Note: The controls for hiding layers are different from the controls for hiding objects.

All on: This button will select all of the layers in the list and make all the layers visible in the AutoCAD view.

All off: This button will unselect all the layers in the list and hide all the layers in the AutoCAD view.

Spaces and Blocks:

Pool Studio AutoCAD Spaces and BlocksVizTerra AutoCAD Spaces and BlocksThe Spaces and Blocks box lists the spaces and blocks contained in the AutoCAD file. Spaces represent the main design and any construction pages created for printing. The blocks represent templates used in the AutoCAD file and often include landscaping symbols. Pool Studio or VizTerra simply imports the information already contained in the AutoCAD file.

Spaces and Blocks Names: The names for the Model Space and Paper Spaces are standard for AutoCAD files. The block names are chosen when the blocks are created. It is not possible to change these names in Pool Studio or VizTerra. Pool Studio and VizTerra simply copy the names in the AutoCAD file.

Model Space: In AutoCAD files, the Model Space is the main drawing. The Model Space is nearly the same as the 2D view in Pool Studio or VizTerra. All AutoCAD files will have a Model Space. Nearly everything you will be importing from the AutoCAD file will be found in the Model Space. The majority of the time you are working in the AutoCAD view you will be working in the Model Space.

Paper Spaces: In AutoCAD files, the Paper Spaces are construction plans prepared for printing. The Paper Spaces are nearly the same as the Construction Stage in Pool Studio or VizTerra. Not all AutoCAD files will have Paper Spaces. You will primarily import from Paper Spaces when working in the Construction Stage.

Blocks: In AutoCAD files, Blocks contain templates and symbols especially for plants and trees. Selecting a Block from the list will display just the contents of that one Block in the AutoCAD view. This makes it easy to import templates and symbols from the AutoCAD file into the Pool Studio and VizTerra library. Symbols can only be saved into the Pool Studio and VizTerra library in the Construction Stage.

Line Colors in the AutoCAD View

Pool Studio AutoCAD Line Colors in the AutoCAD ViewVizTerra AutoCAD Line Colors in AutoCAD View

Pool Studio and VizTerra do not import line colors from the AutoCAD file. When the file is loaded in the AutoCAD view all the lines will be white. Importing and hiding lines may change the line colors based on the settings you select under AutoCAD Options.

Imported Object Color: When the Change imported object color box is checked under AutoCAD Options, lines and shapes in the AutoCAD view will change color when imported. This makes it easy to see which shapes have already been imported into the Pool Studio or VizTerra project. The imported object color may be changed by using the color button to the right of the check box.

Hidden Object Color: When the Show hidden objects box is checked under AutoCAD Options, lines and shapes that have been hidden in the AutoCAD view will appear. While these hidden objects will be revealed, they will have a different line color to set them apart from the other objects in the AutoCAD view. If the objects are unhidden, the line color will change back to white. The line color for hidden objects may be changed by using the color button to the right of the check box.

Displaying the AutoCAD View as a Background Image

Pool Studio AutoCAD Displaying as Background ImageVizTerra AutoCAD Displaying as Background Image

Some lines and shapes in the AutoCAD file may have been drawn in such a way as to be impractical to import into the Pool Studio or VizTerra project. For instance, an arc may have been drawn as several small straight lines. Such an arc would be difficult to weld into a complete shape in Pool Studio or VizTerra. Since it is simply easier to redraw the arc, the AutoCAD view can be displayed as background image to use as a guide for tracing.

Please Note: This feature is not available in the Construction Stage.

AutoCAD View Menu Bar Button: The button to display the AutoCAD view as a background image is located on the AutoCAD view Menu bar. Pressing this button will collapse the AutoCAD view and display it as a background image.

Position and Scale of the AutoCAD Background Image: The AutoCAD view will be displayed as a background image on the grid of the 2D view. The scale and the position of the background image on the grid will be determined by the current position of the reference points and the current AutoCAD scale. Moving the reference point on the grid will change where the background image appears. Adjusting the AutoCAD scale will change the scale the background image appears in.

Returning to the AutoCAD View: The Display AutoCAD view as Background Image button will appear on the 2D view tool bar while the AutoCAD view is displayed as a background image. Pressing the button will remove the background image and return the AutoCAD view to normal.

AutoCAD View in the Construction Stage

Pool Studio AutoCAD View in the Construction StageVizTerra AutoCAD View in Construction Stage

The AutoCAD view functions nearly the same in the Construction Stage as it does in other stages. You can import objects from the AutoCAD view into any of the blocks on the construction page. The Construction Stage is also the only stage where symbols can be imported from the AutoCAD view into the Pool Studio or VizTerra library. Some functions of the AutoCAD view have been removed in the Construction Stage.

Differences from the Design Stages: In the Construction Stage, the AutoCAD view may not be displayed as a background image. This button is therefore removed from the AutoCAD tool bar. Also because each block has its own reference point, it is not possible to lock the AutoCAD view to the view in the blocks. This button has been removed as well.

Block Reference Points: Each block on the construction page has its own reference point. You may move the reference points of each block independently of the others. Since each block has its own point, it is not possible to lock the AutoCAD view to the block view.

Importing Symbols and Templates from the AutoCAD View into the Library

VizTerra AutoCAD Importing Symbols and Templates into LibraryPool Studio AutoCAD Importing Symbols and Templates from the AutoCAD into LibraryLandscaping symbols and other templates are saved as blocks in the AutoCAD file. All the blocks in the AutoCAD view are listed in the Spaces and Blocks box under AutoCAD Options. While most templates can be saved to the Pool Studio or VizTerra library in their corresponding stages, landscaping symbols can only be saved to the library in the Construction Stage.

Selecting Symbols and Templates from the Spaces and Blocks Box: The Spaces and Blocks box under AutoCAD Options lists all of the templates and symbols in the AutoCAD view. When a block is selected, only the contents of that block, the template or symbol, will appear in the AutoCAD view.

Saving Templates from Blocks to the Pool Studio or VizTerra Library: Any shape imported from the AutoCAD view into the Pool Studio or VizTerra project may be saved to the library. Once the shape has been imported it may be selected and saved to the library the same as an other shape in the Pool Studio or VizTerra project. Selecting the block name from the Spaces and Blocks list will display just the template contained in that block in the AutoCAD view. It is important that all templates be imported into the correct stage. For example, pool or hardscape templates need to be imported to the Pool Shape or Hardscapes Stage and saved to the library from that stage.

Saving Symbols from Blocks to the Construction Stage Library

Pool Studio AutoCAD Create TemplateMany blocks in the AutoCAD file may be symbols, especially plant and tree symbols. These symbols can be saved to the Pool Studio or VizTerra library only in the Construction Stage. In VizTerra, once saved to the library, these imported symbols may be assigned to plants and trees and other items in the VizTerra library.

Selecting the block name from the Spaces and Blocks list will display just the symbol contained in that block in the AutoCAD view. The symbol can then be imported into any block on the construction page.

Once the symbol has been imported into the construction page, it can be selected and saved to the library. The symbol will be saved as a Selection template and saved to the Landscaping Symbols category in the Construction Template Library.

Please note that in VizTerra it is very important that you save the symbol in the Landscaping Symbols category. Only symbols in the Landscaping Symbols category can be assigned to items in the library.

Once the symbol has been saved, it may now be assigned to plants and trees and other items in the main VizTerra Library. In the main library, select the item you would like to assign to the new symbol. Press the Edit button to bring up the Edit Object box. The new symbol will now appear under the name you gave it in the symbol list. You may select the symbol from the list and assign it to the library item. If you are editing a plant or tree, you may assign the symbol to any of the container classes. Click Ok, and the library will now use the new symbol for that item.

For more information please see the Plants and Trees and Construction stages.